Mono 1.0 in the 10.3 Tree

I’ve got mono 1.0 in the 10.3 tree now, including monodoc, gtk#, gecko#, gtksourceview#, and libgdiplus. XSP is still crashy, so I’ve removed it for now, and monodevelop still doesn’t run either. Hopefully we’ll get those worked out shortly.
KDE 3.3 is coming along nicely. Most of it is compiling, running into a few minor snags here and there but it’s runnable. I’ll post when I’ve got everything ready for those willing to dig into the experimental tree and give them a shot. 🙂

Share on Facebook

5 comments to Mono 1.0 in the 10.3 Tree

  • PCBEnder

    Latest mono build fails on 10.3 with:
    gcc: Internal error: Segmentation fault (program /usr/libexec/gcc/darwin/ppc/cpp-precomp)
    Please submit a full bug report.
    See for instructions.
    make[3]: *** [alloc.lo] Error 1
    make[2]: *** [all-recursive] Error 1
    make[1]: *** [all-recursive] Error 1
    make: *** [all] Error 2
    ### execution of /var/tmp/tmp.1.oae8Ut failed, exit code 2
    Failed: compiling mono-1.0-2 failed

  • Incandescant

    I got the above error too!
    I’m hoping that you hadn’t finished committing everything to the package tree when I ran my update?
    Any suggestions?

  • Incandescant

    That oughta do it, now I’m gonna be itchin to get on my iBook all day! 🙂

  • mononoke ;-)

    Would it be possible to update mono in the 10.2-gcc3.3 tree as well?
    It only contains a stone-age version of mono right now (0.3something, if I remember correctly)… 🙁

  • No, currently modern mono’s will not build on 10.2 🙁